Dlink DES3200 Dhcp snooping. Пример включение дляпортов 1-10. Активизируйте функцию IP-MAC-Port Binding в режиме DHCP Snooping на портах 1-10.


Чтобы посмотреть этот PDF файл с форматированием и разметкой, скачайте его и откройте на своем компьютере.
2018/04/03 09:45
1/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
Dhcphosts
�4C;L C?@02;5=8O
DHCP
�&#x 8;&#x 2;T&#x5=;&#x8O;&#x A;°¸&#xG5;&#xA:;Ž&#x 0;&#x4@;Z�&#x 8;&#x 2;T&#x5=;&#x8O;&#x A;°¸&#xG5;&#xA:;Ž&#x 0;&#x4@;Z�&#x 8;&#x 2;T&#x5=;&#x8O;&#x A;°¸&#xG5;&#xA:;Ž&#x 0;&#x4@;Z�A5@25@ 8 2545=8O AB0B8G5A:8E 04@5A2 01=5=B2
��&#x8G;Z&#x:8;&#x A;�&#x8G;Z&#x:8;&#x A;�&#x8G;Z&#x:8;&#x A;�4C;L 02B0B8G5A:8 A740QB :=D83C@0F8==K9 D09; 4;O
DHCP
�A5@25@0 8 2=A8B 2
���&#xK,;&#x 2;&#x :;�&#xK,;&#x 2;&#x :;�&#xK,;&#x 2;&#x :;�=53 2A5E ?;L720B5;59 A8AB5K, 2 :B@KE 0:B82878@20= A5@28A
DHCP.
���76=AB8
�&#x8G;Z&#x:0;&#x8G;Z&#x:0;&#x8G;Z&#x:0;&#x8G;Z&#x:0;&#x8G;Z&#x:0;&#x8G;Z&#x:0;2B0B8G5A:5 A740=85 :=D83C@0F8==3 D09;0
ISC DHCP
@82O7:0
IP
:
MAC
��&#x 4;�&#x 4;�&#x0@;&#xH@;�5@540G0 ?;L720B5;O 4?;=8B5;L=KE 0@H@CB2
&#x0 ;0&#x0 ;0&#x0 ;0&#x0 ;0!8AB50 3AB523 2E40
Option 82 (Vlan, PORT, Switch IP, Client MAC)
static arp, ipguard (FreeBSD), ipsentinel (Linux)
#?@02;5=85
DHCP
�=0 C40;Q== A5@25@5
���=8B@8=3 2K40==KE 04@5A2
�����A?;L720=85 =5A:;L:8E A5@25@2 4ABC?0
���AB529 2E4
�����2B 0:B820F8O 8 2:;NG5=85 0:B82=KE 01=5=B2 (?@8 8A?;L720=88 25AB5 A
�4C;5
Ipn
)
�#AB0=2:0
�!740BL B01;8FK 2 1075.
# mysql --default-character-set=utf8 -D abills db/Dhcphosts.sql
��4:;NG5=85 4C;O.
abills/libexec/cong.pl
@MODULES = (
'Dhcphosts'
);
�0AB@9:0
ISC DHCP
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
&#x5@;&#x0 ;Š&#x?0;&#x0H;&#x8=;&#x0 ;&#x?0;( :0G5AB25 ?@85@0 8A?;L7C5BAO 0H8=0 ?4 C?@02;5=85
FreeBSD)
�!18@05
ICS
DHCP
A5@25@
# cd /usr/ports/net/isc-dhcp3-server/
# make
# make install
;O AB0@B0 ?@8 703@C7:5 A8AB5K ?@8?8AK205 2
/etc/rc.conf
dhcpd_enable="YES"
dhcpd_ifaces="em1" #
���&#x 1;Ä[&#x @;�8=B5@D59A, =0 :B@ 1C45B @01B0BL A5@25@
���;O B45;5=8O ;32
DHCP
���&#xK ;@A5@25@0 B 4@C38E A1I5=89 A8AB5K 41028BL 2
/etc/syslog.conf
!dhcpd
*.* /var/log/dhcpd.log
# touch /var/log/dhcpd.log
# killall -1 syslogd
/etc/newsyslog.conf
/var/log/dhcpd.log 600 5 100 * JC
��!1I5=8O
Jan 19 17:12:28 null dhcpd: DHCPDISCOVER from 00:07:e9:19:72:1b via fxp0: network ne3: no free leases
������;L720B5;L =5 65B 02B@878@20BLAO, B0: :0: 53
MAC
=5 2 1075.
Jan 19 18:08:19 null dhcpd: DHCPDISCOVER from 00:07:e9:19:72:1b via fxp0
Jan 19 18:08:19 null dhcpd: DHCPOFFER on 10.128.10.10 to 00:07:e9:19:72:1b via fxp0
Jan 19 18:08:19 null dhcpd: DHCPREQUEST for 10.128.10.10 (10.128.0.1) from 00:07:e9:19:72:1b via fxp0
2018/04/03 09:45
3/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
Jan 19 18:08:19 null dhcpd: DHCPACK on 10.128.10.10 to 00:07:e9:19:72:1b via fxp0
����;L720B5;L CA?5H= ?4:;NG8;AO
�545=85 ;30 2 1075 40==KE
(DHCP
�AB@8O)
# ln -s /usr/abills/Abills/modules/Dhcphosts/dhcp_log2db.pl /usr/abills/libexec/dhcp_log2db.pl
FreeBSD:
?@028
/etc/syslog.conf
5A;8 5ABL
!dhcpd
*.* /var/log/dhcpd.log
�B C40;O5 8 2AB02;O5
!dhcpd
*.* |/usr/abills/libexec/dhcp_log2db.pl
Linux:
/etc/rc.local
tail -F /var/log/dhcpd.log | /usr/abills/libexec/dhcp_log2db.pl
# cd /usr/abills/libexec/
# ln -s ../Abills/modules/Dhcphosts/dhcp_log2db.pl
# killall -1 syslogd
sudo
sudo
��� 1C45B 8A?;L720BLAO 4;O ?5@5:=D83C@0F88 A5@25@0.
# cd /usr/ports/security/sudo && make && make install && make clean
�&#x 2;����@?8AK205 276=ABL 70?CA:0 A5@28A0 A8AB59.
/usr/local/etc/sudoers
# ;O
FreeBSD:
#Allow dhcpd operation without password for webserver user
www ALL = NOPASSWD: /usr/local/etc/rc.d/isc-dhcpd
Option 82
��@8 8A?;L720=88
Options 82
�Ë�Ë�&#x5 ;&#x:0;&#x: ;¥&#x@2;&#x5@;&#x0 ;@:CB0B@K 7024OBAO 2 A8AB55 :0: A5@25@0 4ABC?0
(NAS).
&#x0/;&#x !;&#x5@;%&#x@ ;@/ !8AB50/ !5@25@ 4ABC?0/
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
��51E48K5 ?0@05B@K:
IP
��04@5A. A;8 C :CB0B@0 =5B
IP
����04@5A0 6= 8A?;L720BL
�&#xB ;&#xCG;
¸&#xO ;&#x2 ;°=5ACI5AB2CNI89 B0: :0: = =5 ?@8=805B CG0AB8O 2 02B@870F88
0720=85
�"8? A5@25@0 4ABC?0
other
C:070BL
MAC
���04@5A :CB0B@0 2 =0AB@9:0E
NAS.
���4?;=8B5;L=K5 =0AB@9:8
�0?@A5
IP
&#x0 ;&#x?0;��04@5A0 A8AB50 ? C;G0=8N ?@25@O5B A;54CNI85 ?0@05B@K:
MAC
��:CB0B@0
���@B :CB0B@0
Vlan
:;85=B0
MAC
�:;85=B0 5A;8 2:;NG5=0 ?F8O
$conf{DHCPHOSTS_O82_USE_MAC}=1;
[&#x@ ;&#x=5;&#x ?;&#x@0;[&#x@ ;&#x=5;&#x ?;&#x@0;[&#x@ ;&#x=5;&#x ?;&#x@0;[&#x@ ;&#x=5;&#x ?;&#x@0;&#xC ;&#x?@;�5A;8 ?0@05B@ =5 ?@?8A0= 2 18;8=35 = 83=@8@C5BAO 8 ? =5C ?@25@:0 =5
��?@8AE48B
����[&#x@K;&#x :;�[&#x@K;&#x :;�@8 8A?;L720=88 40==9 ?F88 ?0@05B@K :=D83C@0F88 A5B59 4;6=K 1KBL =5
�B5G5==K8
Deny unknown clients:
Server is authoritative for this shared network:
������;O 8A?;L720=8O 8=48284C0;L=KE =0AB@5: :;0AA2 02B@870F88 ?;L7C9B5AL
��&#x ;&#x@;�2;&#x:C;&#x H;�1;&#x;00;&#x ;&#x@;�2;&#x:C;&#x H;�1;&#x;00;&#x ;&#x@;�2;&#x:C;&#x H;�1;&#x;00;&#x ;&#x@;�2;&#x:C;&#x H;�1;&#x;00;H01;= (@02:C H01;=0 ACI5AB2;OBL B;L: G5@57
&#x0/;&#x ;&#x@C;0/ !8AB50/ @C35/
�(01;=K
&#x0 ;Š&#x?0;&#x0 ;Š&#x?0;&#x0 ;Š&#x?0;&#x0 ;Š&#x?0;&#x0 ;Š&#x?0;&#x0 ;Š&#x?0; ). !8AB50 8A?;L7C5B 40==K9 H01;= B;L: ?@8 2:;NGQ==9 ?F88
$conf{DHCPHOSTS_O82_CLASS_TPL}=1;
dhcphosts_dhcp_conf_o82_class.tpl
���A;8 8A?;L7CNBAO :CB0B@K A @07=K8 ?0@05B@08
Option 82
��=C6= A740BL
���[&#x@0;=5A:;L: ?@028; 02B@870F88 @0745;82 8E ?0@05B@
or
@85@:
Dhcphosts_dhcphosts_dhcp_conf_o82_class.tpl
# LOGIN: %LOGIN%
class \"%OPTION82_NAS_NAME%-%OPTION82_NAS_MAC%-port-%OPTION82_NAS_PORT%\" { match if (substring(option
agent.circuit-id, 24, 14) = \"%OPTION82_NAS_MAC%\"
and substring(option agent.circuit-id, 39, 5) = \"%OPTION82_NAS_PORT%\"
and substring(option agent.circuit-id, 57, 3) = \"%CLIENT_VLAN%\")
or ( substring(option agent.circuit-id, 54, 2)=\"%CLIENT_VLAN%\"
and substring(option agent.circuit-id, 48, 5) = \"%OPTION82_NAS_PORT%\"
and substring(option agent.circuit-id, 35, 12) = ucase(\"%OPTION82_NAS_MAC%\"));
2018/04/03 09:45
5/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
}
��!B@C:BC@0 H01;=0 :=D83C@0F88
dhcpd.conf
Dhcphosts_dhcphosts_dhcp_conf_main.tpl
���3;02=K9 :=D83C@0F8==K9 D09; 2 =53
��2=AOBAO 2A5 1I85 40==K5
0 B0:65 3 A5:F88
%OPTION82_CLASS% -
A5:F8O 2K@065=89
Options 82
1.
(dhcphosts_dhcp_conf_o82_class.tpl)
%NETWORKS% -
!5:F8O
DHCP
A5B59
(dhcphosts_dhcp_conf_subnet.tpl)
2.
%HOSTS% -
��A5:F8O AB0B8G5A:8E EAB2
(dhcphosts_dhcp_conf_host.tpl)
3.
&#x5@;&#xK ;&#xH0;;�&#x5@;&#xK ;&#xH0;;�&#x5@;&#xK ;&#xH0;;�@85@K H01;=2 02B@870F88
;O
foxgate-s-6224-s2
# LOGIN: %LOGIN%
class "%OPTION82_NAS_NAME%-%OPTION82_NAS_MAC%-port-%OPTION82_NAS_PORT%" { match if option
agent.circuit-id="Vlan%CLIENT_VLAN%+Ethernet0/0/%OPTION82_NAS_PORT%" and option agent.remote-
id="%OPTION82_NAS_MAC%";
}
�3
����A;8 2A5 ?@028;L= =0AB@5= 2 ;35
DHCP
�A5@25@0 K 4;6=K 2845BL A;54CNI85
��A1I5=8O:
/var/log/dhcpd.log
Oct 19 18:26:36 billing dhcpd: DHCPDISCOVER from 00:13:77:34:5f:a8 via vlan3
Oct 19 18:26:37 billing dhcpd: DHCPOFFER on 172.23.1.55 to 00:13:77:34:5f:a8 (Druid) via vlan3
Oct 19 18:26:40 billing dhcpd: Lease for 172.23.1.55 is connected to interface 0/3 (add 1 to port
number!), VLAN on switch 1:32
Oct 19 18:26:40 billing dhcpd: Lease for 172.23.1.55 raw option-82 info is CID: 0.3 AID: ac.17.1.32
Oct 19 18:26:40 billing dhcpd: DHCPDISCOVER from 00:13:77:34:5f:a8 (Druid) via vlan3
H81:8
ISC-DHCP
����H81:8 :B@K5 B1@060NBAO 2 D09;5
/var/log/dhcpd.log
A5 A45;0;
DHCP
��AB0@B20; = =5 @0740QB 04@5A0.
�����!:@55 2A53 C 0A =5 4=0 87 A5B59 =5 =0AB@5=0 A;CH0BL 70?@AK =0 0H8E
8=B5@D59A0E.
�&#x ?;�&#x ?;�&#x ?;�;3@8B ?8A:0 H81::
1. ?5@570?CAB8BL
isc-dhcp (
��?@25@8BL A;CH05B ;8 =0 :0:-=81C4L 8=B5@D59A5)
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
H81:0:
No subnet declaration for em1 (no IPv4 addresses).
** Ignoring requests on em1. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface em1 is attached. **
���5 ?@?8A0=K ?4A5B8 4;O :;85=B2. 8A0BL 2
'/usr/local/etc/dhcpd.conf'
��@25@8BL ?@?8A0= ;8
IP (alias)
����4;O C:070=3 8=B5@D59A0 2 C:070=9 ?4A5B8.
��2. ?@25@8BL ;3
'/var/log/dhcpd.log' (
8;8
log.messages)
3. !45;0BL 40? 8=B5@D59A0:
tcp-dump port 67
tcpdump -i
(_" $!
-n port 67
�5@5A5G5=85 04@5A2
/usr/local/etc/dhcpd.conf line 142: lease 10.133.3.26 is declared twice!
pool { range 10.133.3.26;
^
�@25@B5 =5 ?5@5A5:0NBAO ;8 C 0A @5=68
(rage)
&#xKE;&#x 0;&#x4@;Z�2K40205KE 04@5A2
IP guard
����?;=8B5;L=5 @0AH8@5=85 4;O 4C;O
Dhcphosts
��?72;O5B C?@02;OBL
��&#x ?;&#x@8;¢�A0ABOB5;L=K ?@8A25=85
IP-
���04@5A2 ?;L720B5;O8. !8
c
&#x0 ;°B50 02B0B8G5A:8
�&#x8@;Å&#xB ;&#xA?;Š�D@8@C5B A?8A:
IP/MAC-
��������04@5A2, A :B@KE 8 :B@K 6= @01B0BL 2 A5B8. A5
���������AB0;L=K5 ?;L720B5;8 ?@8 ?4:;NG5=88 : A5B8 ?;CG0NB A1I5=85, GB 8E A5B529
�&#x C;«&#x@0;&#x C;«&#x@0;&#x. ;&#x!?;Š�&#x. ;&#x!?;Š�&#x. ;&#x!?;Š�04@5A C65 8A?;L7C5BAO 4@C38 CAB@9AB2. !?8A: 3@0=8G5=8O 4ABC?0 ?5@5
��&#x5=;&#x5=;&#x8O;&#x 4;&#x0=;&#x=K;&#xE ;�&#x5=;&#x5=;&#x8O;&#x 4;&#x0=;&#x=K;&#xE ;�&#x5=;&#x5=;&#x8O;&#x 4;&#x0=;&#x=K;&#xE ;�&#x ?;&#x5@;€&#x ?;&#x5@;€A740QBAO ?A;5 875=5=8O 40==KE 01=5=B2 8 =G=K ?5@848:.
cong.pl
$conf{DHCPHOSTS_IPGUARD_FORMAT}=MAC;
�$@0B ?0@ 4;O
FreeBSD ipguard
MAC -
�����:=B@;8@20BL B;L:
MAC
MAC/IP
���:=B@;8@20BL
MAC
8
IP-
A2O7:8
2018/04/03 09:45
7/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
$conf{DHCPHOSTS_IPGUARD_DENY_TPL}=;
�$@0B 70?8A8
�70?@5I5=
4;O D09;0
����:=D83C@0F8==3
ipguard.
5@55==K5
%IP% - IP
04@5A
%MAC% - MAC
04@5A
%LOGIN% -
�38=
%DEPOSIT% -
�����5?78B. O2;O5BAO B;L: ?@8 2;NGQ==9
�?F88
$conf{DHCPHOSTS_DEPOSITCHECK}
%UID% - ID-
��?;L720B5;O
%EXPIRE% -
0B5 8AB5G5=8O 0::0C=B0
@85@K:
Linux ipsentinel:
$conf{DHCPHOSTS_IPGUARD_DENY_TPL}='%IP% %MAC% #
%LOGIN%; %STATUS%; %DEPOSIT%';
FreeBSD ipguard:
$conf{DHCPHOSTS_IPGUARD_DENY_TPL}=;
$conf{DHCPHOSTS_IPGUARD_ACCEPT_TPL}=;
�$@0B 70?8A8
�@07@5H5=
4;O D09;0
����:=D83C@0F8==3
ipguard.
@85@K:
Linux ipsentinel:
$conf{DHCPHOSTS_IPGUARD_ACCEPT_TPL}='%IP%@!%MAC%
# %LOGIN%; %STATUS%; %DEPOSIT%';
FreeBSD ipguard:
$conf{DHCPHOSTS_IPGUARD_ACCEPT_TPL}='%MAC% %IP%
# %LOGIN%; %STATUS%; %DEPOSIT%';
;O 2=5A5=85 AB0B8G5A:8E 70?8A59
/ System conguration/ DHCP Networks/ IP guard/
Static/
����. @028;0, BCB 1JO2;5==K5, ?O2;ONBAO 2 :=F5 A?8A:0 1I8E ?@028;.
FreeBSD
;O !
FreeBSD
�?@3@00
IP Guard
��&#xK ;&#x8 ;&#x?@;�&#xK ;&#x8 ;&#x?@;�&#xK ;&#x8 ;&#x?@;�&#xK ;&#x8 ;&#x?@;�. 0 1075 MB9 ?@3@0K 8 ?@87248BAO :=B@;L.
# cd /usr/ports/security/ipguard && make && make install && make clean
# cp /usr/local/etc/rc.d/ipguard.sh.sample /usr/local/etc/rc.d/ipguard.sh
# chmod +x /usr/local/etc/rc.d/ipguard.sh
�2=A8 875=5=8O 2 D09;K
/usr/local/etc/rc.d/ipguard.sh
iface=fxp1
daemon_flags="-n 2 -u 60 -x -f /usr/abills/var/ipguard"
0?CA:05
# /usr/local/etc/rc.d/ipguard.sh start
��;O ?@AB@0
MAC/IP-
������?0@, :B@K5 ??0;8 2 A?8A: @07@5HQ==KE, =C6= B:@KBL
5=N A8AB5K
/ System conguration/ DHCP Networks/ IP guard/
84 4;O
$conf{DHCPHOSTS_IPGUARD_FORMAT}=MAC;
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
00:07:e9:19:72:1b 0.0.0.0 # Login: aa1
00:07:e9:19:72:12 0.0.0.0 # Login: aa1
00:07:e9:19:72:22 0.0.0.0 # Login: aa1
84 4;O
$conf{DHCPHOSTS_IPGUARD_FORMAT}=MAC/IP;
00:07:e9:19:72:1b 10.128.10.10 # Login: aa1
00:07:e9:19:72:12 10.128.10.11 # Login: aa1
00:07:e9:19:72:22 10.128.10.15 # Login: aa1
Linux
;O !
Linux
�?@3@00
ipsentinel
84:
10.128.0.109@!00:00:00:00:11:00 # aa1 ACCEPT
10.11.11.12@!00:00:00:ee:aa:01 # aa1 ACCEPT
10.0.0.10 00:16:36:a1:6d:75 # aa1 DENY
ARP Static
0=5A5=85 AB0B8G5A:8E 70?8A59 2
ARP
B01;8FC
abills/libexec/cong.pl
$conf{DHCPHOSTS_IPGUARD_FORMAT}="MAC/IP";
$conf{DHCPHOSTS_RECONFIGURE}="/usr/local/bin/sudo /usr/local/etc/rc.d/isc-dhcpd restart; ".
� '/bin/cat /usr/abills/var/ipguard | /usr/bin/awk \'$1 !~ /#/ { print $2 " " $1 } \'
/usr/abills/var/arp_static ;'.
' /usr/local/bin/sudo /usr/sbin/arp -ad ;'.
' /usr/local/bin/sudo /usr/sbin/arp -f /usr/abills/var/arp_static ';
/usr/local/etc/sudoers
www ALL = NOPASSWD: /usr/sbin/arp
&#x A;&#x5@;%&#x@0;&#x 4;�@85@ C?@02;5=8O C40;Q==K A5@25@ 4ABC?0
�!740=85
dhcp
�����:=D83C@0F8==3 D09;0 =0 C40;Q==
NAS.
�5@5:=D83C@0F8O
DHPC-
A5@25@0.
��!740=85 AB0B8G5A:9
ARP
B01;8FK
$conf{DHCPHOSTS_RECONFIGURE}='/usr/bin/scp -o StrictHostKeyChecking=no -i
/usr/abills/Certs/id_dsa.abills_admin '.
'/usr/local/etc/dhcpd.conf '.
'abills_admin\@10.10.20.16:/usr/local/etc/dhcpd.conf; '.
'/usr/bin/scp -o StrictHostKeyChecking=no -i /usr/abills/Certs/id_dsa.abills_admin
/usr/abills/var/ipguard '.
'abills_admin\@10.10.20.16:/usr/abills/var/ipguard; '.
'/usr/bin/ssh -o StrictHostKeyChecking=no -i /usr/abills/Certs/id_dsa.abills_admin
2018/04/03 09:45
9/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
abills_admin\@10.10.20.16 "/usr/local/bin/sudo /usr/local/etc/rc.d/isc-dhcpd restart;' .
�'/bin/cat /usr/abills/var/ipguard | /usr/bin/awk \'\$1 !~ /#/ { print \$2 \" \" \$1 }\'
/usr/abills/var/arp_static ;'.
' /usr/local/bin/sudo /usr/sbin/arp -ad ;'.
' /usr/local/bin/sudo /usr/sbin/arp -f /usr/abills/var/arp_static "';
03@C7:0
ARP
B01;8FC =0
Mikrotik
$conf{DHCPHOSTS_RECONFIGURE}='/bin/cat /usr/abills/var/ipguard | /usr/bin/awk \'\$1 !~ /#/ { print "/ip
arp add address=" \$2 " mac-address=" \$1 " interface=Norq-ETH " } \' | /usr/bin/ssh -t -i
/usr//abills/Certs/id_dsa.abills_admin abills_admin@10.0.0.3';
����GB1K :=B@;8@20BL A2O7:8
MAC/IP
�B0:65 =C6= 2:;NG8BL =0 8=B5@D59A0
read-only
2
�&#x0:;&#x 0;&#x4@;Z�A5:F88 1CG5=8O 0: 04@5A2
��AB529 0::0C=B
�������AB529 0::0C=B ?@54?;0305B 276=ABL 70@538AB@8@20==K 8
��&#x ?;&#x@0; &#x ?;&#x@0; &#x ?;&#x@0; &#x ?;&#x@0; &#x 8;&#xE ;E&#x?0;02B@878@20==K (85NI8 ?@02 ?;L720BLAO A5BLN A CGQB 8E 45?78B0 8;8
[&#x@0;[&#x@0;[&#x@0;&#x ?;�&#x ?;�&#x ?;�&#x ?;�4@C38E ?0@05B@2) ?;L720B5;O ?;L720BLAO A5BLN 8 ?;CG0BL A28 AB0B8G5A:85
IP-
�&#xO ;&#x=5;p&#x@5;8«&#x@8;&#x@0;&#xO ;&#x=5;p&#x@5;8«&#x@8;&#x@0;&#xO ;&#x=5;p&#x@5;8«&#x@8;&#x@0;&#xO ;&#x=5;p&#x@5;8«&#x@8;&#x@0;&#xO ;&#x=5;p&#x@5;8«&#x@8;&#x@0;04@5A0, 2 B65 2@5O =570@538AB@8@20==K5 8 =502B@878@20==K5 ?;L720B5;8
���&#x =;Æ&#x=0;&#x =;Æ&#x=0;&#x =;Æ&#x=0;??040NB 2 3AB52CN A5BL.  ?A;54CNI5 =C6= =0AB@8BL 3AB52CN A5BL A
�&#x 4;�&#x 4;�&#x ;00;&#x ;00;&#x ;00;&#x ;00;&#x ;00;&#x ;00;&#xC ;&#x?0;3@0=8G5==K 4ABC? (4ABC? B;L: : ?;L720B5;LA:C ?@B0;C 8 B.4. ).
�&#xK ;p&#x?0;&#xK ;p&#x?0;&#xK ;p&#x?0;;O 2:;NG5=8O D@K 70?;=5=8O 40==KE ?;L720B5;5 2=5A8B5 2
���:=D83C@0F8==K9 D09; A;54CNI85 ?F88.
$conf{DV_IP_DISCOVERY}=1:129.168.0.0/24;NET_ID:ADDRESS_RANGE;
 538AB@0F8O
IP/MAC
04@5A0
�:;85=B0 4;O ?A;54CNI59
��2K40G8 AB0B8G5A:3 04@5A0
�40==C :;85=BC 2 A5B8.
&#x0 ;°!8AB50 02B0B8G5A:8 8I5B
��A;54CNI89 A214=K9 04@5A
�8 ?@8A208205B 53 :;85=BC
�?@?8AK20O 2 B01;8F5
�04@5A2
DHCP.
NET_ID
- 2 :0:CN A5BL
�@538AB@8@20BL :;85=B0.
ADDRESS_RANGE
� - 480?07=
��04@5A2 :C40 4;65=
�??040BL
�=570@538AB@8@20==K9
:;85=B. A;8 =5 C:070BL MBC
��?F8N 2A5 :;85=BK ??040NB
�2 1ICN A5BL C:070==CN 2
�[&#x@5;&#x. ;�;;?5@2 ?0@05B@5. (01;=K
A@02=5=8O C:07K20NBAO G5@57
��BG:C A 70?OB9.
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
�0AB@9:0
/ System conguration/ DHCP Networks/
���� !740NBAO 425 A5B8 4;O 3AB523 8 4;O
����������70@538AB@8@20==3 4ABC?0.  ?5@29 A5B8 4;O 3AB523 4ABC?0 =C6= C:070BL
@5=46 2K40205KE
IP-
�04@5A2.
IP Range:
#:07K205
IP,
�����:B@K5 4;6=K 2K4020BLAO 2 3AB52 @5685
����[&#x@ ;�;O 02B@878@20==9 A5B8 MBB ?0@05B@ AB028BL ?CABK.
�������(01;= ?8A0=8O 70@538AB@8@20==3 ?;L720B5;O
dhcphosts_dhcp_conf_host.tpl
# dhcphosts_dhcp_conf_host.tpl
2018/04/03 09:45
11/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
# Login: %LOGIN%
host %HOSTNAME% {
hardware ethernet %MAC%;
fixed-address %IP%;
option routers %ROUTERS%;
%BOOT_FILE%
option routers 10.100.20.1;
}
10.100.20.1
����� - H;N7 4;O 70@538AB@8@20==KE/02B@878@20==KE ?;L720B5;59
leases2db.pl
��@8 8A?;L720=88
DHCP
��&#x 0;&#x 0;&#x 0;A5@25@0 =0 A5@25@5 B45;L= B 18;;8=30 F5;5A1@07=
�������8A?;L720BL 4;O A8=E@=870F88 A 18;;8=3 8 =8B@8=30 - 035=B M:A?@B0
leases2db.pl
��º&#xO ;&#x5:;&#xA?;�º&#xO ;&#x5:;&#xA?;�, :B@K9 70=805BAO 5:A?@B 40==KE 87
dhcpd.leases
2 107C 40==KE
18;;8=30.
����V�@25@:0 8 M:A?@B 40==KE ACI5AB2;O5BAO G5@57 ?@56CB: 2@55=8 C:070==K ?@8
������V�AB0@B5 (? C;G0=8N :064K5 20 A5:C=4) ?@8 CA;288 GB 70 MBB ?@56CB: 2@55=8
1K; 875=Q= D09;
dhcpd.leases.
leases2db.pl
�4;65= 1KBL 70?CI5= =0 A5@25@ A
DHCP
�&#x. ;&#x5=;&#xB ;&#x@0;A5@25@. 35=B @01B05B :0:
��&#x8G;Z&#x:8;&#x ?;&#x@0;&#x8G;Z&#x:8;&#x ?;&#x@0;&#x8G;Z&#x:8;&#x ?;&#x@0;45= 8 02B0B8G5A:8 ?@25@O5B ?@8 AB0@B5 ?@8ACBAB285 4C1;8@CNI8E ?@F5AA2.
�#AB0=2:0:
# cd /usr/abills/libexec/
# ln -s ../Abills/modules/Dhcphosts/leases2db.pl
��;O AB0@B0 8A?;L7C5BAO :0=40
# /usr/abills/libexec/leases2db.pl -d LEASES=/var/db/dhcpd/dhcpd.leases
�!B?
/usr/abills/libexec/leases2db.pl
# /usr/abills/libexec/leases2db.pl stop
0@05B@K:
-d
�0?CAB8BL :0: 45=
-h
�����?IL 2 8A?;L720=88 ?@3@0K
LEASES= &
?CBL :
dhcpd.leases
D09;C
UPDATE_TIME= &
&#xO ;�&#xO ;�@5O 1=2;5=8O
DEBUG= &
&#x 0; 568 B;04:8
NAS_ID=
��� A5@25@0 4ABC?0 (? C;G0=8N 0)
������ˆ&#x =;Æ&#x=0;ˆ&#x =;Æ&#x=0;;O 2:;NG5=8O 2 =8B@8=35 ?@AB@0 40==9 8=D@0F88 =C6= C:070BL ?F8N
$conf{DHCPHOSTS_LEASES}='db';
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
ABillS
�$09; :=D83C@0F88
abills/libexec/cong.pl
$conf{DHCPHOSTS_DEPOSITCHECK}=0.00;
&#x0 ;&#x=0;&#x A;&#xGQ;¼&#x ?;&#x@8;&#x :;�&#x0 ;&#x=0;&#x A;&#xGQ;¼&#x ?;&#x@8;&#x :;�&#x0 ;&#x=0;&#x A;&#xGQ;¼&#x ?;&#x@8;&#x :;�#:07K205BAO AC0 =0 AGQBC ?@8 :B@9
2K4020BL
IP
��04@5A ?;L720B5;O.
$conf{DHCPHOSTS_EXT_DEPOSITCHECK}=0.00;
&#x0 ;&#x=0;&#x 4;�&#x0 ;&#x=0;&#x 4;�&#x0 ;&#x=0;&#x 4;�#:07K205BAO AC0 =0 4?;=8B5;L=
���AGQBC ?@8 :B@9 2K4020BL
IP
04@5A
��?;L720B5;O. 0==K9 ?0@05B@ 855B
��1;LH89 ?@8@8B5B G5
$conf{DHCPHOSTS_DEPOSITCHECK}
$conf{DHCPHOSTS_CONFIG}='/usr/local/etc/dhcpd.conf';
�$09; :=D83C@0F88 4;O
DHCP-
A5@25@0.
�� C;G0=8N
/usr/local/etc/dhcpd.conf
.
��1O70B5;L= ?AB02LB5 =0 D09; ?@020, A
��&#x8 ;&#x@0;:B@K8 @01B05B
WEB-
A5@25@.
$conf{DHCPHOSTS_LEASES}='/var/db/dhcpd/dhcpd.leases';
�� 0A?;65=85
dhcpd.leases
D09;0 4;O
��=8B@8=30 2K40G8
IP
�04@5A2.

�40==K9 D09; =5 ??040NB AB0B8G5A:8
�?@?8A0==K5 =0
MAC
04@5A 04@5A0.
$conf{DHCPHOSTS_LOG_CLEAN_DAYS}=30;
����5@84 E@0=5=8O ;32 2 1075. 
�C;G0=8N 30
$conf{DHCPHOSTS_USE_DV_STATUS}=1;
��A?;L720BL AB0BCAK A5@28A0
Internet
�4;O 4C;O
Dhcphosts.
�!B0BCA 4C;O
Dv
�8A?;L7C5BAO 5A;8 AB0BCA
Dhcphosts
�2:;NG5=
$conf{DHCPHOSTS_RECONFIGURE}='/usr/local/bin/sudo
/usr/local/etc/rc.d/isc-dhcpd restart';
�0=40 4;O ?5@570?CA:0
DHCP-
A5@25@0.
��"0:, :0: 4;O 70?CA:0 A5B523 A5@28A0
���=C6=K ?@020 AC?5@?;L720B5;O (?
�C;G0=8N
root
), A8AB50 ?5@570?CA:05B
��45=, 8A?;L7CO
sudo
.
�0=40
$conf{DHCPHOSTS_RECONFIGURE}
��B0:65 2K?;=O5BAO ?A;5 875=5=8O
[&#x@0;[&#x@0;[&#x@0;&#x5=;&#x5=;ˆ&#x C;&#xGQ;&#xB=;�&#x5=;&#x5=;ˆ&#x C;&#xGQ;&#xB=;�?0@05B@2 CGQB=9 70?8A8 01=5=B0. @8 875=5=88 CGQB=9 70?8A8 01=5=B0
&#x0 ;&#x?5;&#x@5;@&#xQB;&#x :;�&#x5=;&#x=K;&#xE ;&#xI0;;�A8AB50 ?5@540QB :0=45 A;54CNI85 7=0G5=8O ?5@55==KE I01;=0 (?5@55==K5
���&#x8 ;&#x?@;�&#x8 ;&#x?@;�&#x8 ;&#x?@;�H01;=0 4;6=K M:@0=8@20BLAO 7=0:08 ?@F5=B0 A 42CE AB@= %?5@55==0%), 0
&#x5=;&#x=K;&#x5 ;�B0:65 MB8 7=0G5=8O CAB0=02;820NB :0: ?5@55==K5 :@C65=8O .
UID
ID
�5@ 70?8A8
DHCP
HOSTNAME
NETWORK
IP
BOOT_FILE
NEXT_SERVER
EXPIRE
DISABLE
COMMENTS
OPTION_82
2018/04/03 09:45
13/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
PORTS
VID
NAS_ID
@85@
�:0;L=K9
Linux (Ubuntu/Debian)
A5@25@
$conf{DHCPHOSTS_CONFIG}='/etc/dhcp/dhcpd.conf';
$conf{DHCPHOSTS_LEASES}='db';
$conf{DHCPHOSTS_RECONFIGURE}='/usr/bin/sudo /etc/init.d/isc-dhcp-server restart';
!5B8
�/ 0AB@9:0
/ IP (DHCP)
!5B8
02545=85 A5B59 4;O
DHCP-
���A5@25@0. ABL 276=ABL 704020BL AB0B8G5A:85
&#x0@;&#xH@;Ë&#xK,;&#x ?;&#x@0;&#x@8; &#xBL;&#x :;�&#x@8; &#xBL;&#x :;�0@H@CBK, ?@A0B@820BL :=D83C@0F8==K9 D09; 8 ?5@5703@C60BL
DHCP-
A5@25@.
Network name:
0720=85 A5B8
Network address:
�!5B529 04@5A.
(0?@85@: 10.10.1.0)
NETMASK:
0A:0 A5B8
Default router:
��0@H@CB ? C;G0=8N.
IP Range:
�&#xKE;&#x 0;&#x4@;Z�80?07= 2K40205KE 04@5A2.
Static:
��@8 2:;NG5=88 40==9 ?F88
ip
04@5A0 ?C;0 @0740NBAO :0: AB0B8G5A:85
�?@8 @538AB@0F88 CA;C38 2 40==9
dhcp
�A5B8, 5A;8 ?F88 =5BC A8AB50
�&#x8G;Z&#x:8;&#x ?;�&#x8G;Z&#x:8;&#x ?;�&#x8G;Z&#x:8;&#x ?;�02B0B8G5A:8 ?4AB02;O5B 2 :=D83C@0F8==K9 D09;
range
xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
�4;O 40==9 A5B8
0?@5B8BL =58725A=KE
�:;85=B2:
�5 2K4020BL 04@5A0 =570@538AB@8@20==K :;85=B0
��2B@8720==K9 A5@25@ 4;O
��40==9 7=K:
?0@05B@
authoritative; (
�A@8B5
man dhcpd.conf)
Coordinator:
���@48=0B@ A5B8
Phone:
�&#x5@;&#x B;;]�&#x5@;&#x B;;]�&#x5@;&#x B;;]�&#x5@;&#x B;;]�5@ B5;5D=0 :@48=0B@0 A5B8
DNS:
DNS (Domain Name Server).
�!5@25@ 45==KE 8Q=
DOMAINNAME:
�&#x5=;&#x ?;��5= ? C;G0=8N
Disable:
B:;NG8BL A5BL
Guest VLAN:
������AB529 2;0= 4;O 40==9 A5B8. A?;L7C5BAO ?@3@09
snmp_utills.pl
�����4;O ?5@5=A0 4;6=8:2 2 3AB529 2;0=.
�[&#x@0;[&#x@0;A;5 875=5=8O ?0@05B@2 A5B59 =C6= ?5@570?CAB8BL
DHCP.
�����"0:65 276=0 ?5@5:=D83C@0F8O G5@57 :=A;L
# /usr/abills/libexec/periodic daily MODULES=Dhcphosts
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
��!?8A: :;85=B2
��������� 40== 5=N 6= ?@AB@5BL 01=5=B2 8A?;L7CNI8E CA;C3C 8 ?@8725AB8
��?8A: ? =8
/ Customers/ Logins/ IP (DHCP)/
��#?@02;5=8O ?;L720B5;5
��/ ;85=BK / 38=K / =D@0F8O / !5@28AK
/ IP (DHCP)
��02545=85 ?;L720B5;O 4;O 2K40G8 04@5A0
DHCP-
�A5@25@
Host name:
�0720=85 EAB0
Networks:
!5BL
IP:
IP-
��04@5A, :B@K9 2K4020BL :;85=BC
Auto:
��������2B ?@8A25=85 A;54CNI53 A214=3 04@5A0 87 A5B8 :;85=BC. 4@5A0 02B0B8G5A:8
�2K18@0NBAO 87 ?;O
IP Range
A5B8.
Boot File:
�03@C60BL D09; ?@H82:8 A
tftp
Next host:
��%AB 4;O 703@C7:8 D09;0 ?@H82:8
MAC:
MAC
:;85=B0
Expire:
&#xO ;�&#xO ;�@5O :=G0=8O 459AB28O ?@028;0
Disable:
��;:8@20BL
Comments:
�5=B0@88
Option 82
[&#x@K;&#x 4;&#x;O;&#x 0;0@05B@K 4;O ?F88 82
Port
���@B :CB0B@0
VID
Vlan ID
NAS
��@82O70BL : :CB0B@C
:B820F88
IPN:
���:B828@20BL 4;O 40==3
IP
CA;C3C
IPN (IPoE).
��@8 2:;NG5=88 MB9 ?F88 :;85=B 1C45B
�&#x8G;Z&#x:8;&#x 0;&#x:B;‚&#x8@;�&#x8G;Z&#x:8;&#x 0;&#x:B;‚&#x8@;�&#x8G;Z&#x:8;&#x 0;&#x:B;‚&#x8@;�&#x8G;Z&#x:8;&#x 0;&#x:B;‚&#x8@;�&#x8G;Z&#x:8;&#x 0;&#x:B;‚&#x8@;�&#x8G;Z&#x:8;&#x 0;&#x:B;‚&#x8@;�02B0B8G5A:8 0:B828@20BLAO ?@8 ?;68B5;L= 45?78B5 8 0:B82= AB0BCA5 CA;C38
Internet
���02545=85 01=5=B0 4;O 02B@870F88 ?
MAC
���:CB0B@0 8 8 ?@BC
����!740BL A5@25@ 4ABC?0 4;O :CB0B@0
2018/04/03 09:45
15/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
&#x0/;&#x !;&#x5@;%&#x@0;&#x 4;�/ !8AB50/ !5@25@0 4ABC?0/
��70?;=8BL ?;O
IP -
MAC -
�"8? A5@25@ 4ABC?0
- dhcp
�025AB8 CGQB=CN 70?8AL 01=5=B0
(
��/ ;85=BK/ 38=K/ 1028BL
)
�!740BL 5C CA;C3C
Internet
�@?8A0BL 2 CA;C35
IP/DHCP
?0@05B@K:
�A5BL 01=5=B0
�?@B
��:CB0B@
������A;8 01=5=B CA?5H= 02B@878@20;AO 2 6C@=0;5 0:B82=KE A5AA89 ?O2;O5BAO 1
�MB 70?8AL
��/ =8B@8=3
/ Internet/
�. A;8 01=5=BC =5 C40QBAO
�������02B@878@20BLAO =C6= ?@25@8BL 6C@=0; H81: ?4:;NG5=8O
/ BGQB
/
Internet/
H81:0/
���=8B@8=3 2K40==KE 04@5A2
/ Monitoring/ DHCP/
������� =8B@8=35 B1@060NBAO B;L: 04@5A0, 2K40==K5 87 ?C;0 04@5A2. !B0B8G5A:85
04@5A0, ?@82O70==K5 :
MAC,
����2 =8B@8=35 =5 B1@060NBAO.
Freeradius DHCP
Freeradius DHCP
���&#x5=;&#x=0;&#x5=;&#x=0;=5 65B 4=2@55== @01B0BL A
isc-dhcp,
��? MBC ?5@54
�70?CA:
Freeradius DHCP
�B:;NG8B5
isc dhcp,
�5A;8 = 2:;NGQ=
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
��;O 1;55 381:9 @0740G8
IP
���&#x 2;&#xK4;&#x0G;&#x8 ;&#x@5; 04@5A2 1K; @07@01B0= =2K9 5E0=87 2K40G8 04@5A2
�8A?;L7CO DC=:F88
DHCP FreeRadius.
�@58CI5AB20 4C;O:
��&#x5=;&#x8,;&#x =;&#x5 ;&#x=C;&#x6=;&#xK ;&#x?5;&#x@5;p&#x3@;Ç&#x:8;&#x 8;&#x D;�&#x8@;�&#x8@;� 01B0 2 @50;L= 2@55=8, =5 =C6=K ?5@5703@C7:8 8 D@8@20=8O D09;2
�:=D83C@0F88
&#x8G;Z&#x:8;&#xE ;&#x@5;  0740G0 48=08G5A:8E 04@5A2
BACBAB285 ?@82O7:8 :
MAC
�04@5AC 01=5=B0
�[&#x@K;&#x: ;&#x:0;��2B@870F8O CG8BK20O ?0@05B@K: :CB0B@, ?@B
, vlan.
�0@05B@K 3CB
������CG8BK20BLAO 2A5 8;8 ? B45;L=AB8 2 7028A8AB8 B 8E C:070=8O 2 ?@D09;5
�01=5=B0
��������545=85 3AB529 A5B8 4;O =5 02B@878@20==KE 01=5=B2 8 01=5=B2 A
�&#x 1;�;&#x0=; B@8F0B5;L=K 10;0=A
����2B@538AB@0F8O =2KE 01=5=B2
�����!?5F80;L= @07@01B0==K9 H59?5@ 4;O 40==3 4C;O
(ipoe_shapper.pl -
4;O
�H59?5@0 8A?;L7C5BAO 5E0=87
dummynet).
��&#x 0;&#x 0;&#x 0;&#x :;�&#x :;�&#x :;�&#x :;� 01B05B A 2A5 1@C420=85 :B@5 ?445@68205B
DHCP Option 82 (RFC
3046)
� 01B0 A
Mikrotik DHCP
�A5@25@
�0: @01B05B
������4;O 0:B82=KE 01=5=B2 ACI5AB2CNB ?C;K 04@5A2 87 :B@KE =8 2K40NBAO,
�������:=5G= 5A;8 =5 ?@?8A0= 04@5A =0 01=5=B0 AB0B8G5A:8 (B 5ABL ?@?8A0=
���0.0.0.0). 4@5A0 2K40NBAO A ?@8:@5?;Q==KE : A5@25@C 4ABC?0 ?C;2 04@5A2.
������4;O 4;6=8:2 8 =570@538AB@8@20==KE 01=5=B2 2K40NBAO 04@5A0 87 ?C;2
�3AB52KE
IP
2018/04/03 09:45
17/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
��������? :=G0=8N ?5@840 @5=4K 04@5A0 04@5A 01=5=B0 AG8B05BAO A214=K 8
��&#xC ;�65B 2K4020BLAO 4@C3C 01=5=BC
������5A;8 01=5=B ?ABO== @01B05B 8 ? ?@028;0
DHCP
��G5@57 ?;28=C ;87
�������?5@840 B?@02;O5B ?0:5B ?4B25@645=8O B 53 A5A8O ?@4;605BAO
�����?4 MB 2A5 A45;0= H59?5@ :B@K9 ?4=805B ?@028;0 4;O 0:B82=KE
����01=5=B2, 65B ?4=80BL =0 A5@25@0
FreeBSD, Linux,
0 B0:65 =0
�����:CB0B@0E 8 5ABL ?445@6:0 8A?;L720BL =57028A8K5 2=5H=85
�?@3@0K 4;O H59?5@0
���:=5G= 65 ?445@6:0
Option 82 c
����276=ABLN 704020BL H01;=K
�[&#x@0;[&#x@0;����@0A?7=020=8O ?0@05B@2 :CB0B@2, B0: :0: =5 2A5 ?@87248B5;8
����1@C420=8O ?@845@6820NBAO AB0=4@0B2
�:;NG5=85 8 =0AB@9:0
cong.pl
�&#x5=;&#x=0; @?8A0BL =865 ?5@55==9
%AUTH=();
$AUTH{dhcp}='Mac_auth';
����!:?8@20BL 4C;L :0B0;3 18;8=30
cp Mac_auth.pm /usr/abills/Abills/mysql/
��&#x0 ;&#x:0;&#x0 ;&#x:0;&#x0 ;&#x:0;&#x0:;�&#x0:;�&#x0:;�&#x0:;�&#x0:;�&#x0:;�? C;G0=8N A8AB50 :=B@;8@C5B 4C1;8@20=85 0:2, GB1K MB 19B8 =C6= 2 (
�0AB@9:8
/ SQL Commander
) A45;0BL
ALTER TABLE dhcphosts_hosts DROP KEY mac;
ALTER TABLE dhcphosts_hosts DROP KEY ip;
�=0AB@9:0 @048CA
������!:?8@20BL D09; :=D83C@0F88 2 :=D83C@0F8==K9 :0B0;3
/usr/local/etc/
# cp /usr/abills/misc/freeradius/v2/dhcp.conf raddb/sites-enabled/
�#1548B5AL B 2
raddb/dictionary
��?4:;NGQ= 4C;L
dictionary.dhcp
���5A;8 =5 ?4:;NGQ= , - 4102LB5 AB@:C :
$INCLUDE /usr/local/share/freeradius/dictionary.dhcp
�1O70B5;L= 2=5A8B5 875=5=8O 2
dictionary.dhcp
C40;8BL A5:F8N
ATTRIBUTE DHCP-Relay-Agent-Information 82 tlv
BEGIN-TLV DHCP-Relay-Agent-Information
...
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
END-TLV DHCP-Relay-Agent-Information
�41028BL A5:F8N
ATTRIBUTE DHCP-Relay-Agent-Information 82 octets
ATTRIBUTE DHCP-Agent-Circuit-Id 0x0152 octets
ATTRIBUTE DHCP-Agent-Remote-Id 0x0252 octets
���A;8 2A5 ?@H; CA?5H= ?@8 AB0@B5
radiusd -X
�&#x0 ;&#x?0;&#x0 ;&#x?0;&#x0 ;&#x?0;?@3@00 ?:065B GB B:@K;0 67
�?@B 4;O
dhcp
��70?@A2.
Listening on dhcp address 192.168.1.41 port 67 as server dhcp
���?;=8B5;L=K5 ?F88
$conf{DHCPHOSTS_PORT_BASE}=1;
����&#x 5;0&#x 5;0&#x 5;02B@8720BLAO 01=5=B0 A CGQB 53 ?@B0 ?4:;NG5=8O
(SWITCH,PORT).
&#x0 ;
;T‹&#x G;°&#x0 ;
;T‹&#x G;°&#x0 ;
;T‹&#x G;°0: 04@5A =5 CG8BK205BAO. !8AB50 A;548B GB 1K =0 ?@BC 1K; =5
��‡&#x8@;�‡&#x8@;�‡&#x8@;�‡&#x8@;�1;LH5 1 02B0B878@20==3 01=5=B0.
$conf{DHCPHOSTS_SWITCH_MAC_AUTH}='1,2, &';
����������&#x0:;&#x 0;&#x4@;Z&#xC ;&#x?@;&#x8 ;&#x2:;&#x;N;&#xGQ;&#x==;�&#x0:;&#x 0;&#x4@;Z&#xC ;&#x?@;&#x8 ;&#x2:;&#x;N;&#xGQ;&#x==;�!?8A: :CB0B@2 2 :B@KE ?@8=C48B5;L= 02B@878@20BL ? 0: 04@5AC ?@8 2:;NGQ==9 ?F88
$conf{DHCPHOSTS_PORT_BASE}
$conf{DHCPHOSTS_GUEST_POOLS}='VLAN:POOL_ID:EXT_PARAMS'
������&#x 0;&#x 8;&#x 0;&#x A;&#x 0;&#x 1;�;&#x0=; 1JO2;5=85 3AB523 ?C;0 04@5A2. 0==K9 ?C; 2K40QBAO =5 02B@878@20==K 01=5=B0 8 01=5=B0 A B@8F0B5;L=K 10;0=A.
0@05B@K:
VLAN -
�;0= 01=5=B0
POOL_ID -
�&#x5@;&#x ?;;&#x0 ;&#x@5; 5@ ?C;0 04@5A2 2 A8AB55
ABillS (
�&#x0/;&#x !;&#x5@;%&#x@ ;@70248BAO / !8AB50/ !5@25@ 4ABC?0
/ IP Pools)
EXT_PARAMS -
��[&#x@K;&#x 4;&#x;O;&#x 4;&#x0=;&#x=0;[&#x@K;&#x 4;&#x;O;&#x 4;&#x0=;&#x=0;&#x0 ;&#x?@;T�&#x0 ;&#x?@;T����?;=8B5;L=K5 @048CA ?0@05B@K 4;O 40==3 ?C;0. !8AB50 ?@54AB02;O5B 276=ABL 70248BL =0 :064K9
Vlan
���A29 3AB529
����?C;. @028;0 ?C;2 @0745;ONBAO BG:9 A 70?OB9 (;).
@85@:
$conf{DHCPHOSTS_GUEST_POOLS}='0:3:DHCP-Router-Address=10.22.0.1,DHCP-Subnet-Mask=255.255.252.0,DHCP-Domain-Name-Server=192.168.111.254';
$conf{DHCPHOSTS_LEASES}='db';
��:;NG5=85 2 =8B@8=30
leases
A5AA89
$conf{DHCP_FREERADIUS_DEBUG}=1;
&#xK ;� 568K B;04:8
1 -  568 A5AA89 (D09;
: /tmp/rad_dhcp)
&#x 0;&#x 0;&#x 0;2 -  568 B25B2 02B@870F88. ($09;
: /tmp/rad_reply)
&#x 2;&#xK@;&#x5=;‰&#x 4;&#x;O;&#x ?;&#x@0;[&#x@0;3 -  568 2K@065=89 4;O ?@25@:8 ?0@05B@2
Option 82 (
$09;
/tmp/dhcphosts_expr)
$conf{DHCPHOSTS_EXPR}='-';
����������&#x8@;�&#x8@;�&#x8@;�"0: :0: ?@87248B5;8 1@C420=8O (:CB0B@2) =5 2A5340 ?@845@6820NBAO AB0=40@B2 ?@8 D@8@20=85 70?@A2
DHCP Option 82
2 A8AB55
������[&#x@0;1K;0 A740=0 276=ABL 7040BL @53C;O@=5 2K@065=85 4;O ?;CG5=8O =C6=KE ?0@05B@2 87
DHCP
�����70?@A0 . A?;L720BL 4?;=8B5;L=K5
����������[&#x@K;&#x 0;[&#x@K;&#x 0;[&#x@K;&#x 0;2K@065=8O 4;O ?;CG5=8O :@@5:B=KE 40==KE A 70?@A2 B :CB0B@2 2 :B@KE ?0@05B@K ?F88 82 B;8G0NBAO B AB0=40@B=KE.
�&#x 2;&#xK@;&#x5=;&#x8O;&#x G;&#x5@;W&#x B;�&#x 2;&#xK@;&#x5=;&#x8O;&#x G;&#x5@;W&#x B;�D@0B 2K@065=8O G5@57 BG:C A 70?OB9:
�@048CA_?0@0:CA;28O:?5@55==K5
:hex2ansii;
�CA;28O ?5@55==K5 &.
@048CA_?0@0
� - @048CA ?0@0 70?@A0
�CA;28O
�� - CA;28O ?8A:0
Perl
2K@065=85
?5@55==K5
- ?5@55==K5 @57C;LB0B0
VLAN PORT MAC MAC_DEC (
&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�5A;8 0: =5 =C6= ?@51@072K20BL 2 H5AB=04F0B5@8G=K9 87 45AOB5@8G=3
)
PORT_DEC (
�������5A;8 =5 =C6= ?@51@072K20BL ?@B 87 45AOB5@8G=3 2 H5AB=04F0B5@8G=K9 D@0B0)
hex2ansii
�&#x5=;&#x=K;&#xE ;&#x?@;P&#x5=;&#x=K;&#xE ;&#x?@;P&#x5=;&#x=K;&#xE ;&#x?@;P&#x5=;&#x=K;&#xE ;&#x?@;P&#x5=;&#x=K;&#xE ;&#x?@;P - 5A;8 C:070= TBB ?0@05B@ A8AB50 ?5@54 2KG8A;5=85 =C6=KE ?5@55==KE ?@51@07C5B AB@:C A H5AB=04F0B5@8G=3 D@0B0 2
�B5:AB2K9
&#x0 ;&#x?@;&#x8 ;&#x?0;[&#x@0;&#x ?;&#x@0;[&#x@0;&#x ?;&#x@0;[&#x@0;&#x ?;&#x@0;[&#x@0;&#x ?;&#x@0;[&#x@0;&#x ?;&#x@0;[&#x@0;&#x ?;&#x@0;[&#x@0;&#x ?;&#x@0;[&#x@0;&#x ?;&#x@0;A8AB50 ?@8 ?;CG5=88 ?0@05B@0 ?@25@O5B =C6= ;8 8A?;L720BL 2=5H=85 2K@065=8O 5A;8 40 =0G8=05B ?@E48BAO ? A?8A:C ?@8 ??040=88 2
[&#x@K;&#x ?;&#x5@;Q�&#x0 ;&#x?0;?0@05B@K ?5@51@ ?@5:@0I05BAO 8 A8AB50 ?4AB02;O5B 2K1@0==K5
VLAN PORT MAC MAC_DEC (
&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�&#x0:;&#x =;&#x5 ;&#x=C;&#x6=;�5A;8 0: =5 =C6= ?@81@072K20BL 2 45AOB8G=K9
�&#x0 ;‡&#x H;Z&#xB=;ð¸&#x@8;&#xG=;�&#x0 ;‡&#x H;Z&#xB=;ð¸&#x@8;&#xG=;�D@0 87 H5AB=04F0B8@8G=3
) PORT_DEC (
���������5A;8 =5 =C6= ?@81@072K20BL ?@B 87 45AOB5@8G=3 H5AB=04F0B8@8G=3 D@0B0) 2
DHCP-Agent-
Circuit-Id
8
DHCP-Agent-Remote-Id
��40;LH5 C65 84CB AB0=40@B=K5 ?@F54C@K @01BK A
DHCP.
&#x0 ;�&#x0 ;�@8 2:;NG5=88 2K@065=89 A8AB50 B:;NG05B H01;=
������? C;G0=8N 4;O @0A?7=020=8O :CB0B@2
$conf{DHCPHOSTS_AUTH_PARAMS}=1;
������[&#x@0;2B@870F8O ? A2:C?=AB8 70?;=5==KE ?0@05B@2
MAC,PORT,VLAN,NAS_ID
�����@8 8A?;L720=88 40==9 ?F88 B:;NG8B5
$conf{DHCPHOSTS_PORT_BASE}
$conf{DHCPHOSTS_GUEST_STATIC_IP}=1;
���&#x0 ;&#x2K;@&#xQB;&#x 3;�&#x0 ;&#x2K;@&#xQB;&#x 3;�&#xC ;�&#xC ;� C;G0=8N G5@57 :064K9 0;092 ?5@84 A8AB50 2K40QB 3AB52C 01=5=BC =2K5
IP
��&#x0 ;&#x?0;&#x0 ;&#x?0;&#x0 ;&#x?0;04@5A. @8 2:;NG5=88 40==9 ?F88 A8AB50 ?ABO==
�2K40QB BB 65
IP
��&#x5=;&#x5=;‰&#x ?;����A;5 2=5A5=8O :0:8E ;81 875=5=89 ? 4C;N 2 :=D83C@0F8==K9 D09;
?5@5703@C609B5
RADIUS
@85@K K@065=89
Edge-Core ES-3528M
Huawei S2318TP-EI
DHCP-Relay-Agent-Information:0x(01)(04)([0-9a-f]{4})\d{2}([0-9a-f]{2})(02)(06)([0-9a-
f]{12}):ID,SIZE,VLAN,PORT,ID,SIZE,MAC;
Edge-Core ES-3526XA V2
Edge-Core ES-3510MA
Huawei s2326tp-ei (
�5@A8O ?@H82:8
: s2300ei-v100r006c05.cc)
2018/04/03 09:45
19/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
DHCP-Relay-Agent-Information:0x(01)(06)[0-9a-f]{4}([0-9a-f]{4})\d{2}([0-9a-f]{2})(02)(08)[0-9a-
f]{4}([0-9a-f]{12}):ID,SIZE,VLAN,PORT,ID,SIZE,MAC;
GePON Eltex NTE-2
8
NTE-RG
DHCP-Relay-Agent-Information:0x(01)(0b)[0-9a-f]{4}([0-9a-f]{4})[0-9a-f]{10}([0-9a-f]{4})(02)(0b)[0-9a-
f]{10}([0-9a-f]{12}):ID,SIZE,VLAN,PORT,ID,SIZE,MAC;
Foxgate-s-6224-s2
DHCP-Relay-Agent-Information:0x(01)(08)0006([0-9a-f]{4})\d{6}([0-9a-f]{2})(02)(06)([0-9a-
f]{12}):ID,SIZE,VLAN,PORT,ID,SIZE,MAC;
D-link
DHCP-Relay-Agent-Information:0x(01)(06)0004([0-9a-f]{4})\d{2}([0-9a-f]{2})(02)(08)([0-9a-
f]{12}):ID,SIZE,VLAN,PORT,ID,SIZE,MAC;
Dlink DES-3200-26
4;O
Hw A1,B1 Firmware Version1.28.009 , HW C1 Firmware Version
4.00.24 DGS-3120-24SC hw a2 Firmware VersionBuild 2.00.010
DHCP-Relay-Agent-Information:0x(01)(06)0004([0-9a-f]{4})\d{2}([0-9a-f]{2})(02)(080006)([0-9a-
f]{12}):ID,SIZE,VLAN,PORT,ID,SIZE,MAC;
��0==K5  45=5
, DNS, NetMask,
&#x0 ;&#x@Q;&#xB ;&#x2 ;&#x=0;«&#x@0;H;N75 A8AB50 15@QB 2 =0AB@9:0E
DHCP
A5B59 (
/
�0AB@9:0
/ DHCP
!5B8/
��), 8;8 6= 8E C :070BL 2 @048CA ?0@0E A5@25@0
�4ABC?0 (
��/0AB@9:0 /!5@25@ 4ABC?0
).
��?;=8B5;L=K5
Radius
�0@K (C:07K20NBAO 2 0AB@9:0
�/0AB@9:0 /!5@25@
�4ABC?0
)
DHCP-Domain-Name-Server='8.8.8.8'
04@5A
DNS
A5@25@0
DHCP-Subnet-Mask=255.255.255.255
0A:0 A5B8
DHCP-Server-IP-Address='10.2.0.1'
4@5A H;N70
DHCP-Router-Address='10.2.0.1'
4@5A H;N70
Assign-Ports='1,24,25,'
������?@545;5=85 @07@5HQ==KE ?@B2 :CB0B@0.  C;G0=8N
�@07@5H5=K 2A5 ?@BK
��0AB@9:0 A5@25@0 4ABC?0
��/0AB@9:0/ !5@25@ 4ABC?C/
IP:
IP
��04@5A :CB0B@0.
Name:
0720=85
Alive:
&#xO ;;‹;&#xL=;�&#xO ;;‹;&#xL=;�&#xO ;;‹;&#xL=;�&#x 7;&#x0?;&#x@0;&#x 7;&#x0?;&#x@0;@5O 4;8B5;L=AB8 ?5@54 ?2B@=K 70?@A
IP (
�� C;G0=8N 600)
Type:
dhcp
Mac:
��0: 04@5A5 :CB0B@0
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
&#x8G;Z&#x:0;&#xO ;&#x2K;@&#xG0;&#x 0;&#x4@;Z�&#x8G;Z&#x:0;&#xO ;&#x2K;@&#xG0;&#x 0;&#x4@;Z�&#x8G;Z&#x:0;&#xO ;&#x2K;@&#xG0;&#x 0;&#x4@;Z�5A;8 =C6=0 48=08G5A:0O 2K40G0 04@5A2 1O70B5;L= 2K15@8B5 ?C; 4;O
��:CB0B@0
:;NG5=85 H59?5@0
(ipoe_shapper)
����3@0=8G5=85 ?@?CA:059 ?;AK 70=805BAO
/usr/abills/libexec/ipoe_shapper.pl
.
�&#x0 ;&#x@0;���@3@00 @01B05B 2 @5685 45=0 8 :064K9 10 A5:C=4 ?@25@O5B =5B ;8 =2KE
���A5AA89 2 =8B@8=35 18;;8=30 8 70=A8B
IP
���04@5A0 =2KE 01=5=B2 2 B01;8FK
H59?5@0.
 @5685
IPN_SHAPPER
�&#x0 ;;&#xO ;&#x:0;d�&#x0 ;;&#xO ;&#x:0;d�&#x0 ;;&#xO ;&#x:0;d�&#x0 ;;&#xO ;&#x:0;d�&#x0 ;;&#xO ;&#x:0;d�&#x0 ;;&#xO ;&#x:0;d�&#x0 ;;&#xO ;&#x:0;d�?@3@00 4;O :0643 =23 ?4:;NG5=8O 2K?;=O5B
��?4=OB85 ?@028; H59?5@0 ?@3@008
IPN
C?@02;5=8O
($conf{IPN_FW_START_RULE},$conf{IPN_FW_STOP_RULE}).
�"0:65 2 MB @5685
�2K?;=ONBAO ?@028;0
$conf{IPN_FILTER}
0@05B@K
-d
����0?CA:0BL 2 @5685 45=0. ( C;G0=8N 2:;NG5=)
LOG_FILE= &
��CBL : D09;C ;32
UPDATE_TIME= &
������5@84 ?@25@:8 =2KE ?4:;NG5=89 C:07K205BAO 2 A5:C=40E ( C;G0=8N 10 A5:C=4)
DEBUG= &
&#x 0; 568 B;04:8
1-7 (Default: 8)
NAS_IDS=
�&#x5@;&#x A;&#x5@;%&#x@0;&#x 4;�&#x5@;&#x A;&#x5@;%&#x@0;&#x 4;�&#x5@;&#x A;&#x5@;%&#x@0;&#x 4;�&#x5@;&#x A;&#x5@;%&#x@0;&#x 4;�&#x5@;&#x A;&#x5@;%&#x@0;&#x 4;�&#x5@;&#x A;&#x5@;%&#x@0;&#x 4;�&#xL ;&#x?@;;&#x0 ;&#xH5;&#x9?;&#x5@;&#x0 ;&#x;�5@ A5@25@0 4ABC?0 4;O :B@3 ?4=80BL ?@028;0 H59?5@0 ( C;G0=8N: A5)
IPN_SHAPPER
&#x ?;�:;NG8BL @568 ?4=OB8O H59?5@0 ?@028;08
IPN
# cd /usr/abills/libexec/
# ln -s ../Abills/modules/Dhcphosts/ipoe_shapper.pl ipoe_shapper.pl
:;NG5=85:
&#x C;Hµ&#xAL;&#x G;°&#x C;Hµ&#xAL;&#x G;°&#x C;Hµ&#xAL;&#x G;°?5@54 2:;NG5=85 C1548B5AL GB A:@8?B ?4=OB8O H59?5@0 CAB0=2;5=
(/usr/local/etc/rc.d/shaper_start.sh)
/etc/rc.conf
abills_dhcp_shaper="YES"
abills_dhcp_shaper_nas_ids="1,2" #
�������A?8A: A5@25@2 4ABC?0 4;O :=B@;O ?@3@09
ipoe_shaper
���803=AB8:0 8 =8B@8=3
����BA;56820BL H81:8 2K40G8 04@5A2 6= G5@57 5=N
/ BGQB
/ Internet/
H81:0/
&#x 4;�&#x 4;�&#x 4;�@82O7:0 : A5@25@0 4ABC?0 ACI5AB2;O5BAO 8A?;L7CO ?0@05B@
DHCP-Gateway-IP-
Address
:0:
IP
��[&#x@ ;&#x=5;&#x =;	E&#x= ;Š&#x?0;A5@25@0 4ABC?0, 5A;8 MBB ?0@05B@ =5 =0945= 8A?;L7C5BAO ?0@05B@
DHCP-Server-IP-Address
. C4LB5 2=80B5;L=K ?0@05B@
Radius NAS-Identier
=5
�����CG8BK205BAO 8 5A;8 C 20A =5A:;L: A5@25@2 A 48=0:2K
IP
�A8AB50 65B
2018/04/03 09:45
21/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
����&#x ?;�8A?;L720BL ;N19 8E =8E 2 A;CG09= ?@O4:5
����!?8A: H81: 02B@870F88
User Not Exist '00:11:22:11:11:a1' /0not Option82
����!:@55 2A53 70?@A : A5@25@C 84QB =5 ?
Option 82,
0 G5@57
DHCP Broadcast.
�C6=
���=0AB@8BL :CB0B@ =0
Option 82 (
����0AB@9:0 1@C420=8O
)
Can't nd Switch MAC '00:11:22:11:11:a1' or user port '24'
�����&#xC ;&#x:0;�5 =0945= :CB0B@ 8;8 ?4:;NG5==K9 01=5=B : 40==C :CB0B@C. A;8
���8A?;L7C5BAO 02B2@870F8O ?
MAC
�����B340 B;L: :CB0B@.
���CB0B@K 7024OBAO 2 A5:F88 /!8
c
&#x0/;&#x !;&#x5@;%&#x@ ;@B50/ !5@25@ 4ABC?C/
Can't nd MAC, Switch MAC '00:11:22:11:11:a1' port '24'
��2B@870F8O ?
MAC. MAC
��01=5=B0 =5 1=0@C65=
��=8B@8=3 0:B82=KE A5AA89
��/ =8B@8=3
/ Internet/
���B1@060NBAO 0:B82=K5 A5AA88 01=5=B2
���=8B@8=3 @575@20 04@5A2
��/ =8B@8=3
/ DHCP/
��B1@060NBAO 70@575@28@20==K5
IP
[&#x@K;&#x ?;�[&#x@K;&#x ?;�[&#x@K;&#x ?;�04@5A0 8 ?0@05B@K ?4:;NG5=8O 01=5=B2:
���:CB0B@0, ?@B
, VLAN, MAC
04@5A
����0AB@9:0 1@C420=8O
10.0.0.1
4@5A
DHCP
A5@25@0
�&#x0=;&#x4K;&#x 4;&#x;O;&#x =;
&#xB@;�&#x0=;&#x4K;&#x 4;&#x;O;&#x =;
&#xB@;��0=4K 4;O =0AB@9:8 :CB0B@0
L2 (DES-3526/DES-3550):
http://www.dlink.co.il/ru/faq/62/228.html
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
���#0@H@CB870B@ ? C;G0=8N
create iproute default 30.51.8.11
# 04@5A
DHCP
A5@25@0
config dhcp_relay add ipif System 10.0.0.1
config dhcp_relay option_82 state enable
enable dhcp_relay
Dlink DES3200 Dhcp snooping
&#x5@;&#x 2;&#x:;;&#xNG;&#x5=;…&#x 4;&#x;O;&#x?0;&#x5@;&#x 2;&#x:;;&#xNG;&#x5=;…&#x 4;&#x;O;&#x?0;@85@ 2:;NG5=85 4;O?@B2 1-10
enable address_binding dhcp_snoop
�;&#xL=;��;&#xL=;��;&#xL=;��;&#xL=;�&#xKE;&#x 2;&#x ?;&#x@0;&#xKE;&#x 2;&#x ?;&#x@0;#:068B5 0:A80;L=5 :;8G5AB2 A740205KE 2 ?@F5AA5 02B87CG5=8O 70?8A59
IP-
MAC
��=0 ?@B0E 1-10, @02=5 1
config address_binding allow_dhcp_snoop 1-10 total_entries 1
:B82878@C9B5 DC=:F8N
IP-MAC-Port Binding
2 @5685
DHCP Snooping
�=0 ?@B0E 1-10
config address_binding ip_mac ports 1-10 state enable
������0AB@9B5 276=ABL ?5@540G8 =C;523
IP-
���04@5A0 (0.0.0.0) 4;O :@@5:B=9 @01BK
���?@B:;0
DHCP
config address_binding ip_mac ports 1-10 allowzeroip enable
������0AB@9B5 276=ABL ?5@540G8 ?0:5B2 B
DHCP-
A5@25@0
config address_binding ip_mac ports 1-10 forward_dhcppkt enable
Linksys SPS224G4
#
Edge Core
��"5AB8@20;AL =0
ES3510MA.
����?;=8B5;L= 2:;NG5=0 ?F8O
snooping.
ip dhcp snooping
ip dhcp snooping vlan
=B5@D59A
�/Vlan
ip dhcp snooping information option
ip dhcp snooping information policy replace
�����# =0 0?;8=:2KE ?@B0E 1O70B5;L= C:070BL AB0BCA 425@5==K9:
interface ethernet 1/10
ip dhcp snooping trust
2018/04/03 09:45
23/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
Cisco
��! 2:;NGQ==9 ?F859
Snooping
ip dhcp snooping
interface
=B5@D59A
�/Vlan
ip helper-address 10.0.0.1
ip dhcp relay information trusted
foxgate-s-6224-s2
hostname hostname1 #
70405
hostname (
�2 MB ?@85@5 =C65= 1C45B 4;O
Option82)
service dhcp
ip forward-protocol udp bootps
ip dhcp relay information option
ip dhcp snooping enable
ip dhcp snooping information enable
ip dhcp snooping information option remote-id standard
vlan 100 #
�A7405
vlan100
interface ethernet 0/0/1-24 #
&#x ?;�&#x ?;�2K18@05 ?@BK A 1 ? 24
switchport access vlan 100 #
&#x ?;�&#x 4;�&#x 4;�&#x 4;�=07=0G05 ?@B0 4ABC? B;L: 4;O
vlan100
interface ethernet 0/0/26 #
&#x ?;�2K18@05 ?@B 26
switchport mode trunk
switchport trunk allowed vlan 100
ip dhcp snooping trust
interface Vlan100
ip address 192.168.100.2 255.255.255.0
ZTE 2928E
set port statistics mode ingress
set dhcp snooping-and-option82 enable
set dhcp option82 add port 1
set dhcp option82 sub-option port 1 circuit-ID on cisco
set dhcp option82 add port 2
set dhcp option82 sub-option port 2 circuit-ID on cisco
.....
set dhcp option82 add port 25
set dhcp option82 add port 26
set dhcp option82 add port 27
set dhcp port 28 server
set dhcp snooping add port 28
set dhcp option82 add port 28
Huawei s2326tp-ei
�5@A8O ?@H82:8
: s2300ei-v100r006c05.cc
#
!Software Version V100R006C05
#
vlan batch 100 800
#
dhcp enable
dhcp snooping enable
Last update:
2015/12/05 15:52
abills:docs:modules:dhcphosts:ru
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
http://abills.net.ua/wiki/
Printed on 2018/04/03 09:45
dhcp option82 format extend
#
http server load flash:/s2300ei-v100r006c05.web.zip
#
vlan 100
description ManageSwitch
vlan 800
description client_vlan
dhcp snooping enable
dhcp snooping trusted interface GigabitEthernet0/0/1
dhcp option82 rebuild enable interface Ethernet0/0/24
interface Ethernet0/0/24
port link-type access
port default vlan 800
dhcp snooping enable
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100 800
dhcp_tools.pl
����01@ 4?;=8B5;L=KE CB8;8B 4;O @01BK A
DHCP
�&#x8G;Z&#x:0;02B0B8G5A:5 70=5A5=8O
IP/MAC
����04@5A2 ?;L720B5;59 2 4C;L
Dhcphosts.
� 01B05B 2 42CE @5680E:
0=5A5=85
IP/MAC
���A2O7: ?;L720B5;59 87 D09;0.
1.
�$@0B D09;0:
LOGIN[TAB]IP[TAB]MAC[TAB]PORTS[TAB]NAS_ID[TAB]OPTION_82[TAB]VID[TAB]HOSTNAME
 568
ARP
��=8B@0 A8AB50 2KB0A:8205B
IP/MAC
A2O7:8 87
arp
B01;8FK
1.
���&#x8 ;&#x8 ;p&#x=0;A@02=8205B 8E A =;09= ?;L720B5;O8 8 70=A8B 2 107C
�����5@5=A 01=5=B2 87 4=9 A5B8 2 4@C3CN.
# dhcp_tools.pl ADDRESS_SHIFT="NEW_NETWORK_ID:SRC_NET:DST_NET"
NEW_NETWORK_ID
�&#x5@;&#x 2;&#x :;&#x0:;&#xCN;&#x A;[&#xL ;&#x?5;&#x@5;&#x=5;«&#x8 ;�&#x5@;&#x 2;&#x :;&#x0:;&#xCN;&#x A;[&#xL ;&#x?5;&#x@5;&#x=5;«&#x8 ;�=5@ 2 :0:CN A5BL ?5@5=5AB8 01=5=B2
SRC_NET
����BG=0O A5BL 01=5=B2. 0A:0 A5B8 /24 (255.255.255.0)
DST_NET
���20O A5BL 01=5=B2. 0A:0 A5B8 /24 (255.255.255.0)
&#x5=;&#xBK;&#x ?;&#x@0;@3C5=BK ?@3@0K
NETWORK
 A5B8 4;O
ARG grab.
FILE
 568 ?0@A5@0 D09;0
ADDRESS_SHIFT
�����5@5=A 01=5=B2 87 4=9 A5B8 2 4@C3CN
DEBUG
&#x 0; 568 B;04:8
2018/04/03 09:45
25/25
Dhcphosts
Advanced Billing Solution - http://abills.net.ua/wiki/
H81:8
Dlink DES 3026
�&#x5@;&#x0 ;&#x?0;&#x5@;&#x0 ;&#x?0;&#x5@;&#x0 ;&#x?0;=5@0 ?@B2 =0G8=0NBAO A 0 4 25
���?;=8B5;L=
RFC 2132
DHCP
RFC 3046
Option 82
Option 82
Cisco DHCP Snooping
From:
http://abills.net.ua/wiki/
-
Advanced Billing Solution
Permanent link:
http://abills.net.ua/wiki/doku.php/abills:docs:modules:dhcphosts:ru?rev=1429623299
Last update:
2015/12/05 15:52

Приложенные файлы

  • pdf 7819034
    Размер файла: 194 kB Загрузок: 0

Добавить комментарий